Payment Issues

Incident Report for Cards2Cash

Resolved

We are happy to confirm that the issue has been resolved and service has been restored for customers. We apologise if you have had any issues.
Posted Sep 09, 2026 - 14:43 UTC

Investigating

We are currently aware that our card payment provider is having issues accepting card payments.
Posted Sep 09, 2026 - 13:36 UTC
This incident affected: UK - Payment Gateway.